Launcher 2.0 Release

last month by Adam


The launcher has been updated to 2.0. This release bundles Java 11, and if you wish to run the jar directly, requires Java 11. It also includes a new loading splash screen with improved error handling if there is an error when launching the client.

Launcher updates require manually downloading and installing the new launcher. However if you do not have problems with the existing version I would not recommend downloading the newer one just because it is newer.

The Windows binaries remain digitially signed by Alexander Henne for verification. Regardless, Windows SmartScreen tends to block new executables anyway, so if it doesn't work try downloading the old launcher instead.

Adam


Developed with and using Bootstrap, React and Font Awesome Subscribe via RSS